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Configure database fields in MDC-Max  
Before your MDC data can be imported into Excel it must first be made accessible. By default, 
MDC-Max has three mdc database tables where our data can be stored and queried from; 
monitorjob, monitoroperator and monitorprogram. For each of these tables, it can be configured 
what fields they include and thereby what data is available for import into Excel.  
 
For this guide we will use the table monitorjob and the following steps describe how to add 
fields/data to this table in MDC-Max. 
 

1. Open the MDC-Max PC Client and log in with a user that is authorized to make changes 
to the MDC Engine. 

 
2. Select the Setup tab and click the System Setup button to reveal the System Setup tab. In 

the System Setup tab, click the button MDC Engine. 
 

3. In the menu tree, select DB table - Job under Job Setup. This is where the monitorjob 
table is configured. 
 

 
 

4. The list in DB table - Job shows all the fields that are made available in the monitorjob 
table. Use the Add button to add more fields to the table as needed. 
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Import MDC data into Excel 
To create reports with graphs and charts using Excel, you first need to import the MDC data from 
the MDC database located on the CIMCO Database Server. Since Excel do not have built-in 
functions for connecting to MySQL based databases, you need to download and install an ODBC 
driver, which will handle the data connection between the database and Excel. 
 
This section will walk you through how to download, install and configure the MySQL 
Connector/ODBC driver required to import data from the MDC database to a spreadsheet in 
Excel. The MySQL Connector/ODBC is the name for the family of MySQL ODBC drivers that 
provide access to a MySQL database using the industry standard Open Database Connectivity 
(ODBC) API. It is a standardized database driver for Windows, Linux, Mac OSX, and Unix 
platforms. 

1. Download and install the MySQL Connector/ODBC driver 
The MySQL Connector/ODBC driver can be downloaded from mysql.com at this url: 
https://dev.mysql.com/downloads/connector/odbc/ 
 

1. Fill out the form on the page to get a list of installers for your version of Windows. 
Identify the Windows MSI Installer that corresponds with your version of Windows and 
click the Download button.  
 

 
 

2. On the next page called "Begin Your Download", scroll to the bottom of the page and click 
the link "No thanks, just start my download." to skip the login and signup process. This 
will start the download.  
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3. Locate the downloaded file on your computer and run it. This will start the MySQL 
Connector/ODBC Setup Wizard. 
 

4. Click next on the first screen. On the next screen, read and (if you agree) accept the 
License Agreement - then click next. 
 

     
 

5. On the screen "Setup Type", choose Typical and click the Next button. Alternatively, 
choose Custom, if you need to change the destination folder or need to customize the 
installer in other ways.  
 

 
 

6. On the next screen, verify your settings and click the Install button to start the installation 
process.   

 
7. Once the installation has completed, click the Finish button to close the installer.   

  



   Page 6 of 22 
 

        
CIMCO A/S 
Copenhagen, Denmark 

Tel:  +45 45 85 60 50 
Fax: +45 45 85 60 53 

www.cimco.com 
info@cimco.com 

 

2. Configure data sources 
To import data from the MDC database located on the CIMCO Database Server, we need to 
create a so-called data source. A data source associates a particular ODBC driver with the data 
to be accessed through that driver.  
 
To setup or configure existing data sources, open the ODBC Data Sources as shown in the 
following steps. 
 

1. In Windows 10, open the search dialog by clicking the search icon in the taskbar. Search 
for "ODBC" and select either the ODBC Data Sources (32-bit) or ODBC Data Sources (64-
bit) depending on what version of the ODBC driver you installed (32 or 64-bit). It is 
important that the versions match since, otherwise, connections will not work. 
 
Alternatively, the ODBC Data Sources files can be located at: 
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools 
 

 
 

2. Running the ODBC Data Sources will open a window called ODBC Data Source 
Administrator. This window contains several tabs such as User DSN, System DSN and 
File DSN. To add a new data source, select the User DSN tab and click the big Add button 
at the right side of the window. 
 

 
 
A DSN is short for Data Source Name and can be created as either a User DSN or System 
DSN. A User DSN is a data source local to a computer and accessible only by the current 
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user that created the data source. A System DSN is also local to a computer but will be 
available to all users on a computer.  

 
3. In the Create New Data Source dialog, select the MYSQL ODBC 5.3 Unicode Driver and 

click on the Finish button. This brings up a new dialog called MySQL Connector/ODBC 
Data Source Configuration.  
 

 
 

4. In the Data Source Configuration dialog, fill out the form as follows: 
 

 
 
Database Source Name: 
Provide a name for the data source. Since our data source will be used to connect to the 
CIMCO Database Server we will name it "CIMCO Database Server". 
 
Description: 
Provide a description of the data source.  
 
TCP/IP Server: 
The name or IP address of the CIMCO Database Server that we want to connect to and 
that contains the MDC database.  
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5. Port: 
Use the port 3306. If uncertain of the port number, contact your System Administrator.   
 
User: 
Type in "root" as the database username. If uncertain of the username, contact your 
System Administrator.   
 
Password: 
Type in the password for the database server. Again, if uncertain of the password, 
contact your System Administrator.   
 
Database: 
If the previous steps are successful, the Database dropdown will contain all the available 
databases on the server. Select the mdc database. 

 
6. To test the data source, click the Test button to the right of the Databases dropdown. It 

should say "Connection Successful". 
 

7. Close the test dialog and then click the OK button in the Data Source Configuration 
window. The new data source is now configured and available in the list of User DSNs. 
Click the OK button to close the ODBC Data Source Administrator. 

3. Import MDC data 
With the data source configured for the CIMCO Database Server, we can now import the data 
from the MDC database to a spreadsheet in Excel.  
 

1. Open Excel and create a blank spreadsheet.  
 

2. To import data, select the Data tab, click the button Get Data, then click From Other 
Sources and select From ODBC. This brings up the From ODBC dialog. 
 

 
  

3. From the dropdown, select the CIMCO Database Server as the data source name and 
click the OK button. 

 
4. If prompted for a username and password, for the CIMCO Database Server, fill in these 

and click the Connect button.  
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5. Once Excel has successfully connected to the CIMCO Database Server, the Navigator 
dialog will appear. 
 

  
 

6. In the menu tree on left side of the dialog, expand the mdc database and click the table 
monitorjob. A preview of the monitorjob table will appear on the right.  
 
Please note:  
Select monitorprogram or monitoroperator instead, if this is where you have configured 
your mdc data to be stored. 
   

7. Click the Load button to import the monitorjob table. This will create a new sheet with the 
imported data. 
 

 
 

8. For clarity, rename the sheet to MachineData by double-clicking the sheet's tab. The tab 
is located below the sheet.  
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Preparation of imported data 
Once the data from the monitorjob table has been imported and the Excel sheet has been 
renamed to MachineData, the imported data must be modified so it can be properly understood 
by Excel. Unfortunately, Excel interprets all the imported data as text, so we need to make several 
changes such as converting time-based data and setting the proper data types.  
 
We do not modify the imported data in the MachineData sheet directly. Instead, we modify the 
query that Excel uses to fetch the data from the monitorjob table. That way, our changes will 
remain intact when refreshing data from the mdc database. So, all the following steps only have 
to be performed once.  

1. Time conversion and column formats 
With the MachineData sheet active, select the Query tab and then click the Edit button. This 
brings up Excel's Query Editor, which we will use to modify the database query. 
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1.1. Modify time-based data 

The data in the columns starttime and endtime is stored as Unix time. Unix time is defined as the 
number of seconds since midnight (GMT time) on January 1, 1970 - also known as the Unix 
epoch. Excel, however, does not have built-in functions for working with Unix time, so we need to 
recalculate the data in these columns manually. 
 
For every Unix time entry, we need to divide by 86400 (to convert to days) and add by 25569 (the 
number of days between 1 January 1900 and 1 January 1970) - see the following steps. 
 
1 First, select all the cells in the starttime column by clicking the column heading. This will 

highlight all the cells. 
 
2 Select the Transform tab and click the Standard button. From the dropdown, select Divide 

and enter the value 86400. Click OK when done. 
 

 
 

3 Again, with the cells still selected, click the Standard button and select Add. Enter the value 
25569 and click OK when done. 

 
4 Excel will now be able to properly convert the time data in the starttime column when 

changing the columns data format. In the column's header, click the small icon to the left and 
select Date/Time from the dropdown menu. 
 

 
 

5 For endtime, please repeat the steps 1 - 4. 
 
The columns named Column1, Column2, Column3, etc., might also contain time-based data. 
However, data in these columns is much easier to convert since it is normally stored in the 
format hh:mm:ss, which Excel knows how to convert properly.  
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6 Identify all the columns that contain time-based data. In each column's header, click the 
small icon to the left and select Duration from the dropdown menu.  

1.2. Format remaining columns 

For the remaining columns, that do not include text data, we need to specify the proper data type 
as well. Columns that contain percentages need to be recalculated for Excel to properly interpret 
them. The data format for other columns can be set directly such as whole numbers.    
 
1 For each column that contains percentages, select all the cells in that column, select the 

Transform tab, click the Standard button and Divide with the value 10000. Click OK when 
done. 

 
2 In the column's header, click the small icon to the left and select Percentage from the 

dropdown menu. Repeat for all columns with percentages. 
 

 
 

3 For columns that have whole numbers. In the column's header, click the small icon to the left 
and select Whole Number from the dropdown menu. Repeat for other columns with whole 
numbers.   

1.3. Apply changes and refresh data 

When done, close the Query Editor and select Keep when asked to keep the changes. Excel will 
now update the data in the MachineData sheet and apply the changes we just specified using the 
Query Editor. Data can be updated at any time by clicking the Refresh button under the Data tab 
and all the changes will remain intact.   
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2. Include machine names   
If the data in the MachineData sheet does not contain a machine name column, this is because 
this information is not stored in the monitorjob table in the mdc database. In this case, the only 
column identifying a machine is the Port ID (portid), which is not easily understandable when 
used as an identifier in reports. 
 
The machine name, however, can be queried from the machines table in the ncbase database and 
merged with the data in the MachineData sheet. The following steps describe how to do this. 
 
1 Select the Data tab and click the button Get Data. From the dropdown, select From Other 

Sources and click the option From ODBC. This brings up a dialog showing a dropdown with 
the available data sources. 
 

 
 

2 Choose the CIMCO Database Server and click OK. This brings up the Navigator dialog. 
 
3 The Navigator dialog shows all the databases available on the CIMCO Database Server. 

Expand the ncbase database, select the machines table and click Load. 
 

 
 

4 Excel will now create a new sheet with all the data from the machines table. For clarity and 
keeping things ordered, rename the new sheet Machines.   
 

We now have two sheets, MachineData and Machines, which both use their own query. It is not 
possible to simply copy the machine name column to the MachineData sheet, because it will not 
update properly when refreshing the data. Instead, we need to merge the two queries using 
Excel's Query Editor.    
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5 Select the MachineData sheet and then select the Query tab. Click the Edit button to bring up 

the Query Editor. 
 
6 In the Query Editor, select the Home tab and click the button Merge Queries to bring up the 

Merge dialog. 
 

7 At the top of the Merge dialog, the monitorjob table is shown (primary table) and below it a 
dropdown containing the tables we can merge with (related tables). Click the dropdown and 
select machines. This will show the machines table below the dropdown. 
 

 
 

8 In the monitorjob table, select the column portid and in the machines table select the column 
machineid. Click OK to merge the tables. 
 
We simply merge the two tables based on the columns portid and machineid. Since portid 
contains a specific machineid for every entry in monitorjob, it is possible to create a 
relationship between these two columns - a many to one relationship. That way, we can 
prepend all the machine specific data, from the machines table, to the end of every entry in 
the monitorjob table and thereby also gain access to the machinename column.  

 
9 In the MachineData sheet, a new column is now added at the end that contains a Table as 

data for every entry. To show the machine name, go to the new column's header and click the 
small icon to the right. In the dropdown, deselect all column names and select machines 
only. The column header is now called machines.machine and shows the machine name for 
each entry.  
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10 For clarity, rename the new column machinename and drag the column all the way to the left 
so it becomes the first column in the table. This makes it much easier to overview. 
 

 
 

11 Close the Query Editor and select Keep when asked to keep the changes. Excel will now 
update the MachineData sheet and include the machinename column. Since we modified the 
query associated with the MachineData sheet, our changes will remain intact when 
refreshing the data. 
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3. Rename columns for clarity 
It is good practice to rename all the columns, in the MachineData sheet, called Column1, 
Column2, Column3, etc. Otherwise it becomes difficult to discern what data each of these 
columns represent. 
 
1 The actual column names can be found in the MDC-Max PC Client. In the MDC-Max Client, 

select the Setup tab > System Setup > MDC Engine > Job Setup > Db Table - Job. The first 
entry in the list (Running Time) corresponds to Column1, the second (Duration) corresponds 
to Column2, and so forth. 
 

 
 

2 In Excel, select the MachineData sheet and then select the Query tab. Click the Edit button to 
bring up the Query Editor. 
 

3 Rename the columns by double clicking the column headers. This process only has to be 
done once.  
 

4 Once all columns are renamed, close the Query Editor and select Keep when asked to keep 
the changes. Excel will now update the MachineData sheet and the columns will have 
meaningful names. 
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Creating reports 
Once the data in the MachineData sheet has been prepared, we can use the data to create 
reports as needed. The types of reports that can be created depends entirely on what data is 
being collected by MDC-Max and made available in the mdc database.   
 
The following example demonstrates how to create a report showing downtime reasons for all 
machines. We will then expand the example to only show downtime reasons for a single 
machine or cell of machines and finally include downtime reasons by machine and operator. 
 
Once you have created your first report you will have a good understanding of how you can easily 
create other types of reports.   

1. Downtime reasons for all machines 
For reports and charts, we will use Excel's PivotTable and PivotChart functions. PivotTables are 
highly flexible and can be quickly adjusted depending on how you need to display your data. 
PivotCharts are based on PivotTables and will automatically update whenever the PivotTables 
are changed. This means that every time the MachineData sheet is refreshed, all PivotTables and 
PivotCharts will update automatically to reflect any new data. 
 
For more information about PivotTables see: 
https://support.office.com/en-us/article/Create-a-PivotTable-to-analyze-worksheet-data-A9A84538-BFE9-40A9-A8E9-
F99134456576 
 
For more information about PivotCharts see: 
https://support.office.com/en-us/article/Create-a-PivotChart-c1b1e057-6990-4c38-b52b-8255538e7b1c 
 
1 To create a PivotTable, first create a new sheet and rename it Downtime - All Machines. Then 

select the Insert tab and click the PivotTable button to bring up the Create PivotTable dialog. 
  

2 In the dialog, enter monitorjob in the field 
Table/Range and click OK.  
 
A blank PivotTable will be created in the sheet 
and the PivotTable Fields dialog will appear on 
the right side of the screen. This is used to 
configure the PivotTable. 
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3 To configure the PivotTable to show downtime reasons 
for all machines, drag the machinename column from 
the list of columns and down to the Rows field. 
 

4 Again, from the list of columns, drag all the columns 
associated with downtime reasons to the Values field. 
As the columns are dragged into the fields, the 
PivotTable instantly reflects the changes. 
 

Since we want the accumulated time for each downtime 
reason, we need to change how the PivotTable displays the 
columns in the Values field.  
 
5 For each column in the Values field, click and select 

"Value Field Settings" from the dropdown dialog. This 
brings up the Value Field Settings dialog. 

 
6 In the dialog, we can choose the type of calculation we 

want to use to accumulate the data from the selected 
column. Since our downtime column contains time-
based data we will choose Sum from the selection field 
and then click the Number format button at the bottom 
of the dialog.  
 
 
 
 
 

 
7 In the Format Cells dialog, select Time under Category and set Locale to "English (United 

States)". Select the format hh:mm:ss (e.g. 11:45:01). Click OK, and OK again to exit both 
dialogs and apply the changes. Repeat this for every column you have added to the Values 
field.  
 
The format hh:mm:ss, that we need, is only available under English (United States). 

  
The summed downtime columns will automatically be added to the PivotTable. In the PivotTable 
Fields dialog, there is also a field called Columns with an entry called ∑ Values. This is 
automatically created to indicate that the columns in the PivotTable are based on the summed 
columns from the Values field. 
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Now that the PivotTable has been configured, we can insert a PivotChart to visualize the data in 
our PivotTable.  
 
8 To insert a PivotChart, click the Insert tab and then click the PivotChart button. This brings up 

the Insert Chart dialog. 
 

9 On the left side, choose Columns and then select the Clustered Columns layout. Click OK to 
insert the PivotChart in the sheet. 
 

10 Scale the chart and drag to position it as needed. 
 

The PivotChart now shows the accumulated time for every downtime reason since the 
beginning. To filter the time period, we can use a PivotTable Timeline that lets you filter by time, 
and zoom in on the period you want.  
 
11 Select the Insert tab and click the Timeline button to bring up the Insert Timelines dialog. 

 

 
 

12 Select the starttime column to set what column the timeline should be based on and click 
OK. 
 

13 Adjust the timeline to only show data from a specific time period. Scale the timeline and drag 
to position it as needed. 
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We now have a report that shows the accumulated downtime reasons for each machine and for 
a specified time period. The report and its elements can easily be further customized as needed. 
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2. Downtime reasons for a single machine 
From the report, we just created, it is easy to create a new report that only shows data from a 
single machine. 
 
14 Duplicate the sheet Downtime - All Machines by right clicking the sheet tab and selecting 

Move or Copy from the menu. In the dialog that appears, select (move to end) in the field 
Before sheet. Check Create a copy and click OK. 
 

 
 

15 Rename the new sheet to Downtime - MACHINE_NAME where MACHINE_NAME is 
substituted with the name of the machine.  

 
16 In the PivotTable, click on the small arrow icon to the right in the Row Labels column. From 

the dropdown, deselect all machines and select only the machine you want to show. Then 
click OK. 
 

 
 

The PivotTable and PivotChart automatically reflects the update and now only shows data from 
the selected machine.  
 
In this way, a different report (sheet) for every machine can be created in a short amount of time. 
The PivotTable can even be duplicated within a sheet, so you can have a PivotTable and 
PivotChart for each machine within the same sheet. Or, you can filter a PivotTable to show the 
machines in a cell.   
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3. Downtime reasons by machine and operator 
If an operator column is available in the MachineData sheet, we can easily expand our downtime 
report to show downtime reasons by both machine and operator.  
 
1 Select the PivotTable. In the PivotTable Fields dialog on the right, drag the column 

associated with the operator name down below machinename in the Rows field. 
 

 
 
The PivotTable will now have nested rows where a machine name can be expanded to show the 
accumulated downtime reasons for each operator who has worked at the machine. The 
PivotChart might not be able to show nested data in a meaningful way. In that case, a different 
type of chart might visualize the data in a better way. This is a matter of personal preference.    


